View Issue Details

IDProjectCategoryView StatusLast Update
0000108Inno Script StudioGeneralpublic2012-07-19 10:07
ReporterdaFritz84Assigned Totimchilvers 
Status assignedResolutionopen 
PlatformOSWindowsOS Version7
Product Version 
Target VersionFixed in Version 
Summary0000108: backslash in editor view triggers null pointer exception
Descriptiontyping a backslash (e.g. for a path) triggers a null pointer exception in the plain editor view (see attached screen). However copy paste of the same character does work, so I suspect something is wrong with my keyboard configuration. I use a german layout keyboard, so for a backslash I have to type a (ALT + ß) combination.
By now I have tried several combinations and ALT + anything seems to produce the same error.

I strongly suspect, since (ALT + char) is often used as menu shortcut, that it tries to find a menu item corresponding to it and fails.
Steps To ReproduceType any special character that is accessed by (ALT + any char)
TagsNo tags attached.



2011-10-12 20:32


screenshot.PNG (255,884 bytes)
screenshot.PNG (255,884 bytes)


2011-10-12 22:17

administrator   ~0000120

Last edited: 2011-10-12 22:21

View 2 revisions

Have been unable to replicate using a virtual machine set to a German keyboard layout.

If possible please send the error log file (file with .elf file extension) located at C:\Users\%USERNAME%\AppData\Roaming\Kymoto Solutions to


2011-10-13 06:17

reporter   ~0000121

.elf file sent, please check back if you did not receive it.


2012-03-27 19:37

administrator   ~0000198

I am unable to reproduce this issue.

I've have received a German layout keyboard and have been testing with it. Has this error been seen since the initial report?


2012-03-27 20:59

reporter   ~0000199

Last edited: 2012-03-27 21:01

View 2 revisions


just checked with a fresh install and it's still the same.
In order to add more details: My Hardware is a Intel MacBook Pro (2010) with Bootcamp, so it maybe has something to do with the Bootcamp driver combination with Innoscript Studio.

did you get the .elf file I tried to send you back in 2011, or is there any stack dump I can provide you?

Additionally I can ask a friend to install InnoScript Studio on his MacBook Pro (2011) which is running also a dual boot configuration and see if he is also sees this error.

Best Regards.


2012-06-18 22:06

administrator   ~0000346

The bug report file was received, thanks for that.

A beta release of has been released, this is using the Scintilla editor instead of the previous one. The installer for this can be downloaded from:

Could you please try this version and feedback if the issue still exists.


2012-07-16 19:53

reporter   ~0000445

Last edited: 2012-07-16 19:55

View 2 revisions

sorry for the delay, couldn't spend any time on that since I was quite busy lately.

So back to business: Actually bad news, nothing changed so far.
But I thought I would give Spy++ a try to see which window messages got delivered.

I attached a new screenshot which shows the Spy++ Output, just before the error window pops up.

I think the interesting part starts at message <01807> where it says KILLFOCUS hwndGetFocus:(null). Especially that (null) value does not look right. Can you check if you get the same KILLFOCUS on your Installation?

One Last Note. I also tried the Latest Beta in a VM on the same Windows installation and the error doesn't occur there.


2012-07-16 19:53


ScriptStudioALT.PNG (60,027 bytes)
ScriptStudioALT.PNG (60,027 bytes)


2012-07-16 20:07

reporter   ~0000446

OK, I didn't want to delete my last post in case someone finds it useful for historical reasons.

It looks like the language region is the clue. I can confirm the following situation on my MacBook Pro:

1.) Native Windows - German Keyboard Layout: Error
2.) Native Windows - English (USA) Layout: OK
3.) VM Windows - German Keyboard Layout: OK
4.) VM Windows - English (USA) Layout: OK

I also uploaded another screenshot showing the Spy++ output with activated English Keyboard Layout, guess what no strange KILLFOCUS messages. (Although the messages could have been triggered by the Error popup, which would make perfect sense since it steals the focus from the main window)


2012-07-16 20:08



2012-07-19 10:07

administrator   ~0000451

The WM_KILLFOCUS hwndGetFocus:(null) is a standard Windows message thats sent when the window losses focus.

The biggest question is why is it working ok with a German layout in the VM but not on the Native install. I will need to re-purpose a PC to install Windows and set it's locality/keyboard location to German and run some tests to see if I can pin down the issue.

Issue History

Date Modified Username Field Change
2011-10-12 20:32 daFritz84 New Issue
2011-10-12 20:32 daFritz84 File Added: screenshot.PNG
2011-10-12 21:41 timchilvers Assigned To => timchilvers
2011-10-12 21:41 timchilvers Status new => assigned
2011-10-12 22:17 timchilvers Note Added: 0000120
2011-10-12 22:17 timchilvers Status assigned => feedback
2011-10-12 22:21 timchilvers Note Edited: 0000120 View Revisions
2011-10-13 06:17 daFritz84 Note Added: 0000121
2011-10-13 06:17 daFritz84 Status feedback => assigned
2012-03-27 19:37 timchilvers Note Added: 0000198
2012-03-27 19:37 timchilvers Status assigned => feedback
2012-03-27 20:59 daFritz84 Note Added: 0000199
2012-03-27 20:59 daFritz84 Status feedback => assigned
2012-03-27 21:01 daFritz84 Note Edited: 0000199 View Revisions
2012-06-18 22:06 timchilvers Note Added: 0000346
2012-06-18 22:06 timchilvers Status assigned => feedback
2012-07-16 19:53 daFritz84 Note Added: 0000445
2012-07-16 19:53 daFritz84 Status feedback => assigned
2012-07-16 19:53 daFritz84 File Added: ScriptStudioALT.PNG
2012-07-16 19:55 daFritz84 Note Edited: 0000445 View Revisions
2012-07-16 20:07 daFritz84 Note Added: 0000446
2012-07-16 20:08 daFritz84 File Added: ScriptStudioALTEnglish.PNG
2012-07-19 10:07 timchilvers Note Added: 0000451